Discussion:
CentOS 7 & LTSP adventures, success.
(too old to reply)
Barry R Cisna
2015-01-02 20:58:44 UTC
Permalink
Hello All,

Thought this may be of interest to some here.
Decided to see how an install of LTSP on CentOS 7 would go,so here are
my findings and long story short LTSP can work on CentOS 7!

1) Fresh install of CentOS 7
2) Do the standard install of the ltsp repo.rpm
3)" yum -y install ltsp-server", fails with three dependencies not
fulfilled.
4) add the epel & repoforge repos., still fails with xorg-x11-xdm not
found
5) find this rpm on net in i386 and force install
6) ltsp-server now installs fine on server, and ltsp-build-client builds
fine as well.
7) thin client boots but fails login, same as a recent CentOS 6.6 & LTSP
with root trying to get a login from ssh right behind the standard user?

Plan B:

1) rename /tftpboot/ltsp and /opt/ltsp to ltsp_OLD on CentOS 7 server.

1a) from a working 8 month old install of LTSP on CentOS 6.6 on server
rsync -avz /var/lib/tftpboot/ltsp remoteCentOS7:/var/lib/tftpboot/
rsync -avz /opt/ltsp remoteCentOS7:/opt/
2a) restart nfs & xinetd services
3a) ltsp-update-sshkeys & ltsp-update-kernels
4a) boot client - login success!
5a) usb sticks & sound works.
6a) #optional, install latest google chrome on server with,
http://tecadmin.net/install-google-chrome-in-centos-rhel-and-fedora/

Not necessary but all of the recent ltsp/k12linux server gets frequent
flash-plugin/plugin-container crashes using latest Firefox,
flash-plugin .
This is a known problem running flash-plugin on remote displays.

Hope this may help someone.

Barry

Loading...