Discussion:
usb on Centos& ( was : reduce image size / speed up boot process )
(too old to reply)
j***@telenet.be
2015-07-07 09:41:42 UTC
Permalink
One additional question: does usb work in you environment at the moment?

greetings, Johan

---
Johan,

Let me note that I still work on CentOS 6 (I don't tested K12Linux on CentOS 7 deeply). On CentOS 6 USB work fine. You should remeber to add LTSP users to fuse group. Users don't joined to fuse group don't use USB devices on thin client machine.

I noted next small problem with USB devices connected to thin client machine. On CentOS 6 GNOME environment shows connected to thin client machine usb device icon only. XFCE and KDE don't although USB device is mounted (this note concerns LTSP environment only). I prepared own script, which support this luck. You can check connected USB device (on the directory /media/username/device_name, on CentOS 7 /run/media/username/device_name - on CentOS 7 I suppose this directory, but I am not sure).
Perhaps you have the same problem.

Best regards,
Radek


Hello Radek, hello All,

can I ask for some advise regarding usb on my ( experimental ) Centos7 setup?

I created group fuse manualy and added my user to the group.
In lts.conf I have a line
LOCALDEV=True
When inserting the usb, I see nothing in dmesg. I don't have a working Centos6 install where I can look what should happen.
The stick does not get mounted on /media of on /run/media/user

I don't have the deeper understanding on how usb works on ltsp to troubleshoot this further.
So any help would be appreciated.

greetings, Johan
Radek Bursztynowski
2015-07-07 12:04:21 UTC
Permalink
Johan,

Yes, it works. I am formating at the moment new hdd connected to the thin client terminal with Scientific Linux 6.1 i686 image.

Best regards,
Radek

-----


One additional question: does usb work in you environment at the moment?

greetings, Johan

---
Johan,

Let me note that I still work on CentOS 6 (I don't tested K12Linux on CentOS 7 deeply). On CentOS 6 USB work fine. You should remeber to add LTSP users to fuse group. Users don't joined to fuse group don't use USB devices on thin client machine.

I noted next small problem with USB devices connected to thin client machine. On CentOS 6 GNOME environment shows connected to thin client machine usb device icon only. XFCE and KDE don't although USB device is mounted (this note concerns LTSP environment only). I prepared own script, which support this luck. You can check connected USB device (on the directory /media/username/device_name, on CentOS 7 /run/media/username/device_name - on CentOS 7 I suppose this directory, but I am not sure).
Perhaps you have the same problem.

Best regards,
Radek


Hello Radek, hello All,

can I ask for some advise regarding usb on my ( experimental ) Centos7 setup?

I created group fuse manualy and added my user to the group.
In lts.conf I have a line
LOCALDEV=True
When inserting the usb, I see nothing in dmesg. I don't have a working Centos6 install where I can look what should happen.
The stick does not get mounted on /media of on /run/media/user

I don't have the deeper understanding on how usb works on ltsp to troubleshoot this further.
So any help would be appreciated.

greetings, Johan



_______________________________________________
K12OSN mailing list
***@redhat.com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>;

Loading...